大智慧黄金四区主图指标公式

时间:2019-10-14 01:10:02 作者:股票公式
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

{J黄金四区}
DRAWGBKlast(DATE>900101,strip(RGB(0,0,150),RGB(0,0,50),1));
DRAWTEXTABS(15,5,'('+STKLABEL+') '+ STKNAME+''),Color00FFFF,LINETHICK2;
DRAWTEXTABS(10,20,'总股本: '+NUMTOSTRn(FINANCE2(35)/10000,1)+'亿股'),Color0088ff,LINETHICK2;
DRAWTEXTABS(10,35,'流通A股: '+NUMTOSTRn(FINANCE2(37)/10000,1)+'亿股'),Color00ff00,LINETHICK2;
DRAWTEXTABS(10,50,'市盈率: '+NUMTOSTRn(DYNAINFO(39),1)+'倍'),Color8800ff,LINETHICK2;
{K线}
STICKLINE(OPEN>=CLOSE ,H ,L,0,0 ),COLOR00FF00,LAYER2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLORFFFF00,LAYER2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR777700,LAYER2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR668800,LAYER2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR559900,LAYER2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR44AA00,LAYER2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR33BB00,LAYER2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR22CC00,LAYER2;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00EE00,LAYER2;
STICKLINE(CLOSE>OPEN,H,L,0,0) ,COLOR0000FF,LAYER2;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000088;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR0000AA;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000EE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
BC:=(2*C+H+L)/4;
MC5:EMA(MA(BC,5),2),Color99FF99,DOTLINE;
PARTLINE(MC5,(MC5>REF(MC5,1)),rgb(255,0,0) ),LINETHICK3,LAYER0;
X:=BARSLAST(DISPSTATUS=1)+1;
P:=BACKSET(DISPSTATUS=2,X/2+1);
K:=BARSLAST(CROSS(P,0.5))+1;
KJ:=HHVALL(HIGH)-LLVALL(LOW);
平衡:=IF(K>=0,LLVALL(LOW)+KJ/2,0);
压力:=IF(K>=0,HHVALL(HIGH)-KJ*0.191,平衡);
支撑:=IF(K>=0,LLVALL(LOW)+KJ*0.191,平衡);
DRAWRECTABS(180,1,200+(HHV(HIGH,K))*300/C ,80 ,rgb(0,0,255)),Color0000FF,LINETHICK2,LAYER3;
DRAWRECTABS(185,4,200+(压力)*300/C ,70 ,rgb(140,0,60)),Color99FF99,LAYER2;
DRAWRECTABS(190,7,200+(平衡)*300/C ,60 ,rgb(0,120,0)),Colorff00FF,LAYER1;
DRAWRECTABS(195,10,200+(支撑)*300/C ,50 ,rgb(80,0,80)),Color00ffFF,LAYER0;
DRAWRECTABS(200,21,200+(C)*300/C ,39 ,rgb(10,10,10)),Color0077FF,LINETHICK1,LAYER0;
DRAWTEXTABS(170,90,'【支撑 '+NUMTOSTRn(支撑,2)+' 元】'),Color00FFff,LINETHICK2,LAYER0;
DRAWTEXTABS(305,90,'【平衡 '+NUMTOSTRn(平衡,2)+' 元】'),Color44FF99,LINETHICK2,LAYER0;
DRAWTEXTABS(440,90,'【压力 '+NUMTOSTRn(压力,2)+' 元】'),Color0044FF,LINETHICK2,LAYER0;
DRAWTEXTABS(220,23,'【四区周期:--→ '+K+'天】'),Color00FFFF,LINETHICK2,LAYER0;
{www.zbgs.net 指标公式网_大智慧股票指标公式}
FILLRGN(压力,HHVALL(HIGH),X>K,RGB(0,0,255)),PRECIS2,LAYER7;{该行设置背景色A}
FILLRGN(平衡,压力,X>K,RGB(90,0,60)),PRECIS2,LAYER7;{该行设置背景色B}
FILLRGN(支撑,平衡,X>K,RGB(0,80,0)),PRECIS2,LAYER7;{该行设置背景色C}
FILLRGN(LLVALL(LOW),支撑,X>K,RGB(60,40,0)),PRECIS2,LAYER7;{该行设置背景色D}
M13:IF(K>=0,MA(C,13),0),COLOR00FFff;
M21:IF(K>=0,MA(C,21),0),COLOR00ff00;
M55:IF(K>=0,MA(C,55),0),COLOR0077ff;
A1:=hhv(h,X); {x:=500}
A2:=llv(l,X);
A3:=(A1+A2)/2;
K0:(0.5*A1+0.5*A2),COLOR00ffff;
K1:IF(K>=0,(0.618*A1+0.382*A2),0),COLOR0000ff,DOTLINE;
K2:IF(K>=0,A2+(A1-A2)*0.74,0),DOTLINE;
K3:IF(K>=0,A2+(A1-A2)*0.865,0),DOTLINE;
K4:A2+(A1-A2)*0.98,COLOR0077ff,LINETHICK2;{最高}
K5:IF(K>=0,(0.382*A1+0.618*A2),0),COLOR0598ff,DOTLINE;
K6:IF(K>=0,A1-(A1-A2)*0.74,0),DOTLINE;
K7:IF(K>=0,A1-(A1-A2)*0.865,0),COLOR99ff99,DOTLINE;
K8:A1-(A1-A2)*0.98,COLORBLUE,LINETHICK2;{最低}
nnl:=DISPSTATUS=2;
DRAWTEXT(nnl,a1*0.998,'最高--→'+A1+'元'),ALIGN1,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,K3,'0.865-→'+NUMTOSTRN(K3,2)+'元'),ALIGN1,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,K2,'0.742-→'+NUMTOSTRN(K2,2)+'元'),ALIGN1,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,K1,'0.618-→'+NUMTOSTRN(K1,2)+'元'),ALIGN1,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,K0,'0.500-→'+NUMTOSTRN(K0,2)+'元'),ALIGN1,Color00FF00,LINETHICK1;
DRAWTEXT(nnl,K5,'0.382-→'+NUMTOSTRN(K5,2)+'元'),ALIGN1,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,K6,'0.258-→'+NUMTOSTRN(K6,2)+'元'),ALIGN1,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,K7,'0.135-→'+NUMTOSTRN(K7,2)+'元'),ALIGN1,Color99FF99,LINETHICK1;
DRAWTEXT(nnl,a2*1,'最低--→'+A2+'元'),ALIGN1,VALIGN2,Color0047FF,LINETHICK1;
HX:=HHVALL(x);
GX:(HX- x )+1,PRECIS0,LINETHICK0;
DRAWTEXT(GX=6,K0,'6'),COLORYELLOW;
DRAWTEXT(GX=9,K0,'9'),COLORYELLOW;
DRAWTEXT(GX=12,K0,'12'),COLORYELLOW;
DRAWTEXT(GX=15,K0,'15'),COLORYELLOW;
DRAWTEXT(GX=18,K0,'18'),COLORYELLOW;
DRAWTEXT(GX=21,K0,'21'),COLORYELLOW;
DRAWTEXT(GX=24,K0,'24'),COLORYELLOW;
DRAWTEXT(GX=27,K0,'27'),COLORYELLOW;
DRAWTEXT(GX=30,K0,'30'),COLORYELLOW;
DRAWTEXT(GX=33,K0,'33'),COLORYELLOW;
DRAWTEXT(GX=36,K0,'36'),COLORYELLOW;
DRAWTEXT(GX=39,K0,'39'),COLORYELLOW;
DRAWTEXT(GX=42,K0,'42'),COLORYELLOW;
DRAWTEXT(GX=45,K0,'45'),COLORYELLOW;
DRAWTEXT(GX=50,K0,'50'),COLORYELLOW;
DRAWTEXT(GX=60,K0,'60'),COLORYELLOW;

后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至:1754122403@qq.com 进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)