通达信筹码拉一波指标公式

时间:2019-09-05 19:20:01 作者:股票公式
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

M1:=3;
M2:=3;
{定海神针;蓝柱距离吻筹点越近,暴发力度越大、}
VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
凤尾鱼:=STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND
REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),1.5,0,6,0),COLORBLUE;
STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND
REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),100,0,4,0),COLORBLUE;
DRAWTEXT(凤尾鱼,54,' ---定海神针'),COLORCYAN;
{跃上金坑.与主图K线黄金坑配合使用。}
A1J:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,10))/EMA(CLOSE,10)); {23}
A2J:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1J);
金线王:=EMA(A2J,5)*1;{200}
金线王2:=EMA(A2J,200)*1.118;{200}
条件:=(C-REF(C,1))/REF(C,1)*100>8;
金K线:=CROSS(C,金线王) AND 条件;
RRFJ:=金K线,STICK;
STICKLINE(IF(RRFJ,-120,0),+80,0,2,0),COLORLIMAGENTA;{COLOR000088;}
DRAWTEXT(RRFJ,42,'---迎财神'),COLORYELLOW;
{要拉一波}
VAR1A:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR4AA:=CLOSE/(REF(CLOSE,1))>1.05 AND (HIGH/CLOSE<1.01);{1.05;1.01}
游资进场:=(FILTER(VAR4AA>0,13)AND DYNAINFO(4)>0)*8,COLORYELLOW;{34}
A10:=10,COLORYELLOW;
{STICKLINE(XYSHSL>2.1 AND CYS13>5,53,86,5,0 ),COLOR000055;}
STICKLINE(游资进场,0,45,2,0),COLORWHITE;{白色柱}
LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));{4/12}
拉升:=FILTER(LS,58);
{铁算盘附图;该指标因采用了三个周期共振编写,如果移到主图上会出现信号3天滞后飘移。}
DD11:0,COLORFF33FF;{0.9}
DD22:0,COLORGREEN;{1.2}
{黄金柱}
M:=30;
N:=15;
AJ:=HHV(H,M)=H;
AJT:=BARSLAST(AJ);
AJ1:=LLV(L,N)=L;
AJ1T:=BARSLAST(AJ1);
TJ:=HHV(H,M)=H;
TJT:BARSLAST(TJ)NODRAW;
TJ1T:=BARSLAST(AJ1);
{STICKLINE((TJT=0,H,TJ1T=0) AND AJ1 AND FILTERX(AJ1,TJT+1) ,REF(L,TJ1T)
,REF(H,TJT),0,0)COLORBLUE,LINETHICK3;}
OUT:=STICKLINE((TJT=0,H,TJ1T=0) AND AJ1 AND FILTERX(AJ1,TJT+1) ,REF(L,TJ1T)
,REF(H,TJT),0,0),COLORBLUE,LINETHICK3;
STICKLINE(OUT>-100,100,80,4,0),COLORGRAY,LINETHICK2;{深灰色柱}
{DRAWTEXT(OUT,82,'----底'),COLORYELLOW;}
SVAR1:='SM波段王.NOTEXTVBR4#DAY'=1;
VBR3:=SVAR1;
VBR4:=SVAR1;
YK:'KDJ.K#MONTH' NODRAW;
YD:'KDJ.D#MONTH' NODRAW;
ZK:'KDJ.K#WEEK' NODRAW;
ZD:='KDJ.D#WEEK' NODRAW;
YY:='三强引用.KK#MONTH' NODRAW;
ZZ:='三强引用.KK#WEEK' NODRAW;
日买:='KDJ.K#DAY">"KDJ.D#DAY';
ZXG:=ZZ=1;
YXG:=YY=1;
多共振:=FILTER(CROSS(日买 AND ZXG AND YXG AND REF(ZK,1)<50,0.5),5)COLORYELLOW, NODRAW;
{XGH:STICKLINE(多共振=1,92,100,4,0)COLORLIRED;
DRAWTEXT(XGH,96,'底'),COLORCYAN;}
{KDJ日金}
日K:="KDJ.K#DAY"(9,3,3);{9/3/3}
日D:="KDJ.D#DAY"(9,3,3);
{DRAWICON(日K>日D,0.1,32);
DRAWICON(日K<日D,0.1,2);
DRAWTEXT(ISLASTBAR=1,0.1,'日K');}
{MACD日金}
日DIF:="MACD.DIF#DAY"(12,26,9);{12/26/9}
日DEA:="MACD.DEA#DAY"(12,26,9);
{DRAWICON(日DIF>日DEA,0.2.1,32);
DRAWICON(日DIF<日DEA,0.2,2);
DRAWTEXT(ISLASTBAR=1,0.2,'日M');}
{RSI日}
日RSI:="RSI.RSI1#DAY"(5);{5}
{DRAWICON(日RSI>50,0.3,32);
DRAWICON(日RSI<50,0.3,2);
DRAWTEXT(ISLASTBAR=1,0.3,'日R');}
{KDJ周金}
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
{DRAWICON(周K>周D,0.4,13);
DRAWICON(周K<周D,0.4,2);
DRAWTEXT(ISLASTBAR=1,0.4,'周K');}
{MACD周金}
周DIF:="MACD.DIF#WEEK"(12,26,9);{12/26/9}
周DEA:="MACD.DEA#WEEK"(12,26,9);
{DRAWICON(周DIF>周DEA,0.5,13);{13}
{DRAWICON(周DIF<周DEA,0.5,2);
DRAWTEXT(ISLASTBAR=1,0.5,'周M');}
{RSI周}
周RSI:="RSI.RSI1#WEEK"(9);{9}
{DRAWICON(周RSI>50,0.6,13);
DRAWICON(周RSI<50,0.6,2);
DRAWTEXT(ISLASTBAR=1,0.6,'周R');}
{KDJ月金}
月K:="KDJ.K#MONTH"(9,3,3);
月D:="KDJ.D#MONTH"(9,3,3);
{DRAWICON(月K>月D,0.7,33);
DRAWICON(月K<月D,0.7,2);
DRAWTEXT(ISLASTBAR=1,0.7,'月K');}
{MACD月金}
月DIF:="MACD.DIF#MONTH"(12,26,9);{12/26/9}
月DEA:="MACD.DEA#MONTH"(12,26,9);
{DRAWICON(月DIF>月DEA,0.8,33);
DRAWICON(月DIF<月DEA,0.8,2);
DRAWTEXT(ISLASTBAR=1,0.8,'月M');}
{RSI月}
月RSI:="RSI.RSI1#MONTH"(9);{9}
{DRAWICON(月RSI>50,0.9,33);
DRAWICON(月RSI<50,0.9,2);
DRAWTEXT(ISLASTBAR=1,0.9,'月R');}
X1:=日K>日D;
X2:=日DIF>日DEA;
X3:=日RSI>50;
X4:=周K>周D;
X5:=周DIF>周DEA;
X6:=周RSI>50;
X7:=月K>月D;
X8:=月DIF>月DEA;
X9:=月RSI>50;
黑马初显:=X1 AND X2 AND X3 AND X4 AND X5 AND X6 AND X7 AND X8 AND X9;
STICKLINE(黑马初显,120,110,8.12,0),COLORRED;
STICKLINE(黑马初显 AND C/REF(C,1)>1.095,120,110,4.66,0),COLORYELLOW;
STICKLINE(黑马初显 AND C/REF(C,1)>1.095,120,110,2.06,0),COLORRED;
{DRAWTEXT(黑马初显,13,'-飚'),COLORYELLOW;}
月RSI1:="RSI.RSI1#MONTH"(9),COLORWHITE;
A:=月RSI1>50;
首月R:=CROSS(A>REF(A,1),0.5),COLORLIGRAY,LINETHICK3;
STICKLINE(首月R,100,63,5,0),COLORLIGRAY,LINETHICK3;
{DRAWTEXT(首月R,70.11,' --月振底'),COLORCYAN;}
月DIF1:="MACD.DIF#MONTH"(12,26,9)COLORYELLOW;
月DEA1:="MACD.DEA#MONTH"(12,26,9)COLORYELLOW;
AA:=月DIF1>月DEA1;
首月M:=CROSS(AA>REF(AA,1),0.5)COLORYELLOW;
STICKLINE(首月M,100,85,5,0),COLORYELLOW;
{DRAWTEXT(首月M,86,' --月共振'),COLORWHITE;}
月K1:="KDJ.K#MONTH"(9,3,3),COLORMAGENTA;
月D1:="KDJ.D#MONTH"(9,3,3),COLORMAGENTA;
AAA:=月K1>月D1;
首月K:=CROSS(AAA>REF(AAA,1),0.5),COLORMAGENTA,LINETHICK3;
STICKLINE(首月K,1.1,1.05,5,0),COLORMAGENTA,LINETHICK3;
周RSI1:="RSI.RSI1#WEEK"(9),COLORGREEN;
AAAA:=周RSI1>50;
首周R:=CROSS(AAAA>REF(AAAA,1),0.5),COLORRED,LINETHICK4;
STICKLINE(首周R,10.05,21,5,0),COLORBROWN,LINETHICK4;
{DRAWTEXT(首周R,20.03,' --周共振'),COLORLIRED;}
周DIF1:="MACD.DIF#WEEK"(12,26,9),COLORCYAN;
周DEA1:="MACD.DEA#WEEK"(12,26,9),COLORCYAN;
AAAAA:=周DIF1>周DEA1;
首周M:=CROSS(AAAAA>REF(AAAAA,1),0.5),COLORCYAN;
STICKLINE(首周M,1,10,5,0),COLORCYAN;
周K1:="KDJ.K#WEEK"(9,3,3),COLORBLUE;
周D1:="KDJ.D#WEEK"(9,3,3),COLORBLUE;
AAAAAA:=周K1>周D1;
首周K:=CROSS(AAAAAA>REF(AAAAAA,1),0.5),COLORBLUE;
STICKLINE(首周K,31.05,20,5,0),COLORLIMAGENTA,LINETHICK1;
STICKLINE(首周K,30.95,20.91,5,0),COLORGREEN;
DRAWTEXT(首周K,30.935,' --马坑'),COLORCYAN;
{DRAWTEXT(黑马初显,13,'-飚'),COLORYELLOW;}
{KDJ;参数:N:2、90、9;M1:2、30、3;M2:2、30、3;}
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1),COLORWHITE;
D:=SMA(K,M2,1);
J:3*K-2*D,COLORMAGENTA;
{●主图黄K底买}
VAR1H:=REF(LOW,1);
VAR2H:=(SMA(ABS(LOW-VAR1H),13,1))/(SMA(MAX(LOW-VAR1H,0),13,1))*4;
VAR3H:=EMA(VAR2H,13);
VAR4H:=LLV(LOW,34);
VAR5H:=EMA(IF(LOW<=VAR4H,VAR3H,0),3);
VAR6H:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)
+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR7H:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)
+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR8H:=VAR6H<REF(VAR7H,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
STICKLINE(VAR8H AND COUNT(VAR8H,18)=1,-10,-100,3,0),COLORLIMAGENTA;{粉色住}
{DRAWTEXT(VAR8H AND COUNT(VAR8H,18)=1,-24,'●主图黄K底买'),COLORYELLOW;}
{庄家起爆点幅图; 来自于水月蓝天2019年6月22日19点发帖:第一条龙}
VAR3AP:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AP:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AP>0),91,0);
XG:=(FILTER((VAR4AP>90),45)),COLORYELLOW;
STICKLINE(XG,-30,0,2,0),COLORGREEN;
{DRAWTEXT(XG>0,-11,'资金异动'),COLORYELLOW;}
{龙凤呈祥}
RSVP:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*20-20;
KV:=SMA(RSVP,3,1);
DV:=SMA(KV,3,1);
JV:=3*KV-2*DV;
ZDZK1:=EMA(JV,6);
ZDZK2:=REF(ZDZK1,1);
凤:=IF(ZDZK1>=ZDZK2,ZDZK1+2,ZDZK2);
雉:=IF(ZDZK2-ZDZK1,ZDZK2,ZDZK1);
MTM:=C-REF(C,1);
龙:=30*EMA(EMA(MTM,50),50)/EMA(EMA(ABS(MTM),61),61);
凰:=MA(龙,6);
龙凤呈祥:=CROSS(凰<龙,0.13) AND 龙>凤 AND 凤>雉;
STICKLINE(龙凤呈祥,-25,-100,2,0),COLORWHITE;
{DRAWTEXT(龙凤呈祥,-15,' 龙凤呈祥'),COLORWHITE;}
{芝麻开门要拉一波}
VAR1S:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR4AS:=CLOSE/(REF(CLOSE,1))>1.05 AND (HIGH/CLOSE<1.01);{1.05;1.01}
游资进场S:=(FILTER(VAR4AS>0,34)AND DYNAINFO(4)>0)*8,COLORYELLOW;
A10S:=10;
{STICKLINE(XYSHSL>2.1 AND CYS13>5,53,86,5,0 ),COLOR000055;}
STICKLINE(游资进场S,-100,-55,1,0),COLORBLUE;{绿色柱}
DRAWTEXT(游资进场S,-35,' 要拉一波'),COLORMAGENTA;
LSS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
拉升S:=FILTER(LSS,58);
STICKLINE(拉升S,-100,-35,0.001,0),COLORYELLOW;
DRAWTEXT(拉升S,-47,'---芝麻开门'),COLORCYAN;
DRAWICON(拉升S,-38.2,9);
DRAWTEXT(VAR8H AND COUNT(VAR8H,18)=1,-24,'●主图黄K底买'),COLORYELLOW;
{筹码捉主升附图}
VAR1:=(CLOSE*2+HIGH+LOW)/1;{2、4}
VAR2:=EMA(VAR1,3)-EMA(VAR1,10);{13、34}
VAR3:=EMA(VAR2,3);{5}
{SHZJX:=(-2)*(VAR2-VAR3)*3.8;}
ZLZJX:=2*(VAR2-VAR3)*3.8;
{STICKLINE(ZLZJX>0,0,ZLZJX*10,3.2,4),COLORRED;
STICKLINE(ZLZJX<0,0,ZLZJX*10,3.2,4),COLORGREEN;}
主力资金线:=ZLZJX,COLORLIRED,LINETHICK2;
VAR4:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR4,1))/REF(VAR4,1)*30;
{A10:=CROSS(控盘,0);
无庄控盘:IF(控盘<0,控盘,0),COLORYELLOW,NODRAW;
开始控盘:IF(A10,15,0),LINETHICK3,COLORMAGENTA;}
有庄控盘:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED;
主力资金:=((100)*(EMA(EMA(MTM,3),3)))/(EMA(EMA(ABS(MTM),3),3)),COLORRED,LINETHICK2;{原6}
移动筹码:=((100)*(EMA(EMA(MTM,20),20)))/(EMA(EMA(ABS(MTM),20),20)),COLORYELLOW,LINETHICK2;{原26}
游资:=((100)*(EMA(EMA(MTM,8),8)))/(EMA(EMA(ABS(MTM),8),8)),COLORMAGENTA,LINETHICK2;{原12}
散户:(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20))*100,COLORGREEN,LINETHICK1;{原24}
零轴线:0,COLORGRAY,DOTLINE,LINETHICK1;
十天主力持仓:8*WINNER(CLOSE*0.9)*10,COLORGREEN,DOTLINE;{绿虚线原10;8}
DJ:=主力资金>=散户 AND 移动筹码>=散户 AND 游资>=散户 AND 十天主力持仓>=1;{原40}
DRAWICON(DJ,-5,25);
{庄筹线上穿散户线变成黄色}
OUT11:=CROSS(十天主力持仓,散户);
STICKLINE(OUT11,80,100,2,0),COLORRED;
DRAWTEXT(OUT11,95,'---财'),COLORWHITE;
{主力资金线上穿散户}
OUT1:=CROSS(主力资金线,散户);
STICKLINE(OUT1,70,85,2,0),COLORBLUE;
DRAWTEXT(OUT1,77,'---神'),COLORCYAN;
DRAWTEXT(OUT,80,'---底'),COLORYELLOW;
{红上绿下趋势附图}
X_1:=LLV(MA((LOW+HIGH+3*CLOSE+OPEN)/6,6),89);
散筹:=EMA((LOW+HIGH+3*CLOSE+OPEN)/6*(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,8)-LLV(LOW,8))*20/10+X_1,2),COLORGREEN,LINETHICK2;
趋势:=1.86*EMA(CLOSE,3)-EMA(CLOSE,17),COLORRED,LINETHICK2;{原3、5}
X_2:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
X_3:=IF(MA(CLOSE,17)<X_2,X_2,MA(CLOSE,17));
浮筹:=X_3-(EMA(CLOSE,3)-X_3),COLORGREEN,LINETHICK2;
{庄筹线上穿散户线;飚在财中或右侧一天内考虑。在左侧放弃!}
OUTC:=CROSS(趋势,浮筹);
STICKLINE(OUTC,58,70,2,0),COLORYELLOW;
DRAWTEXT(OUTC,58,'---飚'),COLORWHITE;
DRAWTEXT(首月R,68,' --月振底'),COLORCYAN;
DRAWTEXT(首月M,86,' --月共振'),COLORWHITE;
DRAWTEXT(首周R,20.03,' --周共振'),COLORLIRED;
XGH:STICKLINE(多共振=1,92,100,4,0)COLORLIRED;
DRAWTEXT(XGH,96,'底'),COLORCYAN;
DRAWTEXT(XG>0,-11,'---资金异动'),COLORCYAN;
DRAWTEXT(龙凤呈祥,-80,' 龙凤呈祥'),COLORWHITE;
{3指.KDJ}
RSVF:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK0;
KF:=SMA(RSVF,3,1);
DF:=SMA(KF,3,1);
JF:=3*KF-2*DF,LINETHICK0;
{4指.W&R}
能量线:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3),LINETHICK0;
威廉WR:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100,LINETHICK0;
{5指.CCI}
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
五指AF:=WMA((能量线+RSI+JF-威廉WR+CCI)/3,3),COLORBROWN;{5,5}
{秘境之门,买坑不买高!}
流通盘:=CAPITAL/1000000,COLOR7F00FF,LINETHICK0;
ZLCM:=EMA(WINNER(CLOSE)*90,3);{//主力筹码估算70}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*70,3);{//散户筹码估算80}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
散户线F:=INTPART(ZSHTL),COLORBLACK,LINETHICK2;
{五指AF上穿散户线F}
OUT666:=CROSS(五指AF,散户线F);
STICKLINE(OUT666,0,116,0.00001,0),COLORWHITE;
DRAWTEXT(OUT666,109,'-童子探路'),COLORWHITE;
{庄家出现}
{RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KC:=SMA(RSVC,3,1);
DC:=SMA(KC,3,1);
JC:=3*KC-2*DC;
J1C:=REVERSE(JC);
AAC:=REF(MA(C,1),10)>REF(MA(C,60),10);
买点:CROSS(JC,J1C) AND AAC;
STICKLINE(买点,-100,-75,1,0),COLORBLUE;
DRAWTEXT(买点,-75,'★庄家出现'),COLORRED;};

后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至:1754122403@qq.com 进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)