同花顺能量资金谱指标公式

时间:2020-03-17 12:55:02 作者:股票公式
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

OBV:=MA(SUM(IF(C>REF(C,1),VOL,IF(C<REF(C,1),-V,0)),0)/25000,1);
OBVE:=EMA(OBV,2);
OBVDIFF := EMA(OBVE,3) - EMA(OBVE,8);//
ZLCM:=EMA(WINNER(CLOSE)*70,3);//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);//散户筹码估算
ZSHTL:=SHCM/(ZLCM+SHCM)*100;//散户套牢筹码比率
SH8:=EMA(ZSHTL,8);
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;//主力控盘筹码比率
zzlkp5:=MA(zzlkp,5);
zzlkpDiff:=EMA(EMA(EMA(zzlkp-zzlkp5,2),2),2);
ZCMZL:=MA(ZLCM+SHCM,13);//市场筹码总量
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);//走牛天数
ZSHJJ:=EMA(ZSHTL,89);//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);//资金流入强度
ZJLRqd3:=MA(ZJLRqd,3);
STICKLINE(zzljj>REF(zzljj,1) AND zzlkp>zzlkp5 AND OBVDIFF>0 AND EMA(OBVE,3) >REF(EMA(OBVE,3) ,1),110,114,8,0),coloryellow;
STICKLINE( (SH8>zshtl OR SH8<REF(SH8,1)) AND ZJLRqd>0,100,104,8,0),colormagenta;
主力持仓:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
指数趋势:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
主力筹码集中度:=WINNER(C)*100;
STICKLINE(C>0,20,20,5,1),coloryellow;
STICKLINE(C>0,80,80,8,1),colorblue;
STICKLINE(主力筹码集中度>主力持仓 AND ZZLKP>ZZLKP5 AND ZJLRQD>0 ,80,80,8,1),colormagenta;
FILLRGN(zzlkp,zzlkp5,zzlkp>zzlkp5,colorred,zzlkp<zzlkp5,colorgreen);
FILLRGN(ZJLRQD,0,ZJLRQD>0,colorlired,ZJLRQD<0,colorligreen);
zjlUp:=ZJLRqd-MA(ZJLRqd,5)+ZJLRqd;
FILLRGN(ZJLUP,ZJLRqd,ZJLUP>ZJLRqd,coloryellow,ZJLUP<ZJLRqd,colorblue);
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);//散户套牢筹码}
DRAWTEXT(ZCMZL>REF(ZCMZL,1) AND SH8<REF(SH8,1) ,100,'增'),colorwhite;
DRAWTEXT(DKB ,95,'拉'),colorwhite;
DRAWTEXT(ZJLRqd>0 AND ZJLRqd<10 AND ZJLRqd>ZJLRqd3 ,90,'主'),colorwhite;
DRAWTEXT(ZJLRqd>=10 AND ZJLRqd>ZJLRqd3 ,90,'超'),colorwhite;
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,4,0),colorgreen; //主力控盘筹码}
ZJLRqddiff:=EMA(EMA(EMA(ZJLRqd-ZJLRqd3,2),2),2);
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),colorlired; //筑底散兵坑}
STICKLINE(ZZLJJ>REF(ZZLJJ,1) AND ZJLRqd>ZJLRqd3,ZZLKP,ZZLJJ,4,0),colorred; //筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,5,0),COLOR66FFCC; //底部:(ZSHTL>=90),COLOR66FFCC;} {筹码总量上升} IF(ZCMZL,ZCMZL>REF(ZCMZL,1),DRAWNULL),COLOR0066FF,LINETHICK1; {增量资金}; {//------【数值显示】}
散户套牢系数:INTPART(ZSHTL),colorgreen,Linethick2;
主力控盘系数:INTPART(ZZLKP),colorred,Linethick2;
资金流入强度:ZJLRQD,LINETHICK2,colorgray;
主力资金:IF(资金流入强度>0,资金流入强度,DRAWNULL),colorred,Linethick2;
市场筹码总量:INTPART(ZCMZL),colorwhite,NODRAW;
轴:50,colorgreen,DOTLINE,LINETHICK1;
DRAWTEXT(CROSS(主力控盘系数,轴),轴+10,'高度控盘'),coloryellow;
锁仓OK:= ZJLRQD>ZJLRQD3 AND ZJLRQD>0;
//STICKLINE(zjlrqd>0 AND zzlkpDiff>0,107,107+zzlkpDiff,8,0),colorlired;
//STICKLINE(zjlrqd>0 AND zzlkpDiff>0 AND (zzlkpDiff>REF(zzlkpDiff,1) OR ZJLRqd>ZJLRqd3),107,107+zzlkpDiff,8,0),colorred;
STICKLINE(zzlkp>30 AND zzlkp>MA(zzlkp,5) AND zzljj>REF(zzljj,1) AND ZJLRqd>0 AND C>EMA(C,12),109,105,8,0),colorred;
STICKLINE( 锁仓OK AND zzlkp>30 AND zzlkp>MA(zzlkp,5) AND zzljj>REF(zzljj,1) AND ZJLRqd>0 AND C>EMA(C,12),109,105,8,0),colormagenta;
DRAWTEXT(DKB ,95,'拉'),colorwhite;
DRAWTEXT(ZJLRqd>0 AND ZJLRqd<10 AND ZJLRqd>ZJLRqd3 ,90,'主'),colorwhite;
DRAWTEXT(ZJLRqd>=10 AND ZJLRqd>ZJLRqd3 ,90,'超'),colorwhite;
鱼头鱼肚:IF(DKB AND ZJLRqd>0 AND ZJLRqd>ZJLRqd3, 50,0),colorwhite,Linethick2;
整个鱼:IF(zzlkp>zzlkp5 AND ZJLUP>ZJLRqd, 80,0),colorwyellow,Linethick2;

同花顺能量资金谱指标公式的选股公式如下:

后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至:1754122403@qq.com 进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)